# Connection refused errno 111

**URL:** <https://community.openpbs.org/t/connection-refused-errno-111/2444>\
**Category:** Users/Site Administrators\
**Created:** [January 25, 2021, 2:43pm UTC](https://community.openpbs.org/t/connection-refused-errno-111/2444 "2021-01-25T14:43:25Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![songyi719](https://avatars.discourse-cdn.com/v4/letter/s/b5e925/32.png) [@songyi719](https://community.openpbs.org/u/songyi719)\
**Post date:** [January 25, 2021, 2:43pm UTC](https://community.openpbs.org/t/connection-refused-errno-111/2444/1 "2021-01-25T14:43:25Z")

</div>

I just installed openpbs and typed

qsub data.sh

but it returned

Connection refused  
qsub: cannot connect to server songyi719-Thinkpad-X1-Extreme-2nd (errno=111)

server and client is same computer, and firewall is off.

When I typed sudo /etc/init.d/pbs status, it returned

pbs\_server is not running  
pbs\_mom is not running  
ps\_sched is pid 955875  
pbs\_comm is not running

I typed sudo /etc/init.d/pbs start, and it returned

Starting PBS  
/opt/pbs/sbin/pbs\_comm ready (pid=969486), Proxy Name:songyi719-thinkpad-x1-extreme-2nd:17001, Threads:4  
PBS comm  
PBS mom  
PBS scheduler already running.  
pgrep: cannot allocate 4611686018427387903 bytes  
Connecting to PBS dataservice…connected to PBS dataservice@songyi719-ThinkPad-X1-Extreme-2nd  
Licenses valid for 1000000 Floating hosts  
PBS server

and I retyped status, and it showed me same result, and same error occured at qsub.

What can be problem? I’ve changed PBS\_START\_MOM to 1 at pbs.conf too. Could network setting cause issue even though server and client is same pc?

---

<div class="post-metadata">

**Author:** ![adarsh](https://avatars.discourse-cdn.com/v4/letter/a/f07891/32.png) [@adarsh](https://community.openpbs.org/u/adarsh)\
**Post date:** [January 25, 2021, 2:55pm UTC](https://community.openpbs.org/t/connection-refused-errno-111/2444/2 "2021-01-25T14:55:29Z")

</div>

**Please check these:**  
0. please check pbs\_server daemon is up and running ( ps -ef | grep pbs\_ )

1. firewall is turned off
2. SELinux is disabled and system is rebooted (if you disable it now)
3. Ports 15001 to 15007 and 17001 is opened between the headnode and compute nodes (vice versa, even if the all the modules are running on one house)
4. hostname of the pbs server and compute nodes is resolvable via /etc/hosts, DNS (forward and reverse address resolution)

**Please share:**  
/etc/pbs.conf  
/etc/hosts  
output of

1. hostname and hostname -A commands
2. /etc/init.d/pbs status or ps -ef | grep pbs\_

---

<div class="post-metadata">

**Author:** ![songyi719](https://avatars.discourse-cdn.com/v4/letter/s/b5e925/32.png) [@songyi719](https://community.openpbs.org/u/songyi719)\
**Post date:** [January 26, 2021, 4:34am UTC](https://community.openpbs.org/t/connection-refused-errno-111/2444/3 "2021-01-26T04:34:24Z")

</div>

/etc/pbs.conf is

PBS\_SERVER=songyi719-ThinkPad-X1-Extreme-2nd  
PBS\_START\_SERVER=1  
PBS\_START\_SCHED=1  
PBS\_START\_COMM=1  
PBS\_START\_MOM=1  
PBS\_EXEC=/opt/pbs  
PBS\_HOME=/var/spool/pbs  
PBS\_CORE\_LIMIT=unlimited  
PBS\_SCP=/usr/bin/scp

/etc/hosts is

127.0.0.1 localhost  
127.0.1.1 songyi719-ThinkPad-X1-Extreme-2nd

_# The following lines are desirable for IPv6 capable hosts_  
::1 ip6-localhost ip6-loopback  
fe00::0 ip6-localnet  
ff00::0 ip6-mcastprefix  
ff02::1 ip6-allnodes  
ff02::2 ip6-allrouters

output of hostname is

songyi719-ThinkPad-X1-Extreme-2nd

output of hostname -A is also

songyi719-ThinkPad-X1-Extreme-2nd

ps -ef | grep pbs\_ output is

songyi7+ 13763 6459 0 13:31 pts/0 00:00:00 grep --color=auto pbs\_output

firewall is turned off, SELinux is not installed since my system is ubuntu 20.04. I opened all following port.

After I typed sudo /etc/init.d/pbs start, it returned

Starting PBS  
/opt/pbs/sbin/pbs\_comm ready (pid=13950), Proxy Name:songyi719-thinkpad-x1-extreme-2nd:17001, Threads:4  
PBS comm  
PBS mom  
PBS scheduler already running.  
pgrep: cannot allocate 4611686018427387903 bytes  
Connecting to PBS dataservice…connected to PBS dataservice@songyi719-ThinkPad-X1-Extreme-2nd  
Licenses valid for 1000000 Floating hosts  
PBS server

And I typed /etc/inti.d/pbs status, and it returned

pbs\_server is not running  
pbs\_mom is not running  
pbs\_sched is pid 1616  
pbs\_comm is not running

but it showed same error

---

<div class="post-metadata">

**Author:** ![songyi719](https://avatars.discourse-cdn.com/v4/letter/s/b5e925/32.png) [@songyi719](https://community.openpbs.org/u/songyi719)\
**Post date:** [January 26, 2021, 6:43am UTC](https://community.openpbs.org/t/connection-refused-errno-111/2444/4 "2021-01-26T06:43:09Z")

</div>

I solved the problem.

I edited IP address at /etc/hosts to my current IP instead of LoopBack Ip and it is solved… Thanks for help
