# Connection Refused (errno=15010)

**URL:** <https://community.openpbs.org/t/connection-refused-errno-15010/3298>\
**Category:** Users/Site Administrators\
**Created:** [September 30, 2022, 6:36am UTC](https://community.openpbs.org/t/connection-refused-errno-15010/3298 "2022-09-30T06:36:22Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![eclipseye](https://avatars.discourse-cdn.com/v4/letter/e/e495f1/32.png) [@eclipseye](https://community.openpbs.org/u/eclipseye)\
**Post date:** [September 30, 2022, 6:36am UTC](https://community.openpbs.org/t/connection-refused-errno-15010/3298/1 "2022-09-30T06:36:22Z")

</div>

Hello,

I recently installed openpbs on my ubuntu 20.04 workstation.  
There was no error while installing openpbs and start pbs service.  
But I got following error when I type ‘qstat -Bf’ or ‘pbsnodes -a’:

~#qstat -Bf  
Connection refused  
pbsnodes: cannot connect to server mustang, error=15010

Here are some outputs:

~# /etc/init.d/pbs status  
pbs\_server is pid 23483  
pbs\_mom is pid 3178  
pbs\_sched is pid 3191  
pbs\_comm is 3162

~# ps -ef |grep pbs\_  
root 3162 1 0 15:10 ? 00:00:00 /opt/pbs/sbin/pbs\_comm  
root 3178 1 0 15:10 ? 00:00:00 /opt/pbs/sbin/pbs\_mom  
root 3191 1 0 15:10 ? 00:00:00 /opt/pbs/sbin/pbs\_sched  
root 23901 1 0 15:35 ? 00:00:00 /opt/pbs/sbin/pbs\_server.bin  
root 23904 1 0 15:35 ? 00:00:00 /opt/pbs/sbin/pbs\_ds\_monitor monitor  
root 23931 23901 0 15:35 ? 00:00:00 sh -c /opt/pbs/sbin/pbs\_ds\_systemd  
root 23932 23931 0 15:35 ? 00:00:00 /bin/sh /opt/pbs/sbin/pbs\_ds\_systemd

~# sestatus  
SELinux status: disabled

~# firewall-cmd --list-ports  
15001/tcp 22/tcp 80/tcp 15002/tcp 15003/tcp 15004/tcp 15005/tcp 15006/tcp 15007/tcp 15008/tcp 15009/tcp 17001/tcp

~# tail /var/spool/pbs/server\_logs/20220930  
09/30/2022 15:10:37;0002;Server@mustang;Svr;Log;Log opened  
09/30/2022 15:10:37;0002;Server@mustang;Svr;Server@mustang;pbs\_version=20.0.0  
09/30/2022 15:10:37;0002;Server@mustang;Svr;Server@mustang;pbs\_build=mach=N/A:security=N/A:configure\_args=N/A  
09/30/2022 15:10:37;0002;Server@mustang;Svr;Server@mustang;hostname=mustang;pbs\_leaf\_name=N/A;pbs\_mom\_node\_name=N/A  
09/30/2022 15:10:37;0002;Server@mustang;Svr;Server@mustang;ipv4 interface lo: ip6-loopback  
09/30/2022 15:10:37;0002;Server@mustang;Svr;Server@mustang;ipv6 interface lo: ip6-loopback  
09/30/2022 15:10:37;0006;Server@mustang;Fil;Server@mustang;Version 20.0.0, started, initialization type = 1  
09/30/2022 15:10:38;0002;Server@mustang;Svr;Server@mustang;pbs\_status\_db exit code 1  
09/30/2022 15:10:38;0002;Server@mustang;Svr;Server@mustang;Starting PBS dataservice  
09/30/2022 15:10:50;0002;Server@mustang;Svr;Server@mustang;Starting PBS dataservice  
09/30/2022 15:11:02;0002;Server@mustang;Svr;Server@mustang;pbs\_status\_db exit code 1  
09/30/2022 15:11:02;0002;Server@mustang;Svr;Server@mustang;Starting PBS dataservice  
09/30/2022 15:11:15;0002;Server@mustang;Svr;Server@mustang;Starting PBS dataservice  
09/30/2022 15:11:27;0002;Server@mustang;Svr;Server@mustang;pbs\_status\_db exit code 1  
09/30/2022 15:11:27;0002;Server@mustang;Svr;Server@mustang;Starting PBS dataservice  
09/30/2022 15:11:43;0002;Server@mustang;Svr;Server@mustang;Starting PBS dataservice  
09/30/2022 15:11:54;0002;Server@mustang;Svr;Server@mustang;pbs\_status\_db exit code 1  
09/30/2022 15:11:54;0002;Server@mustang;Svr;Server@mustang;Starting PBS dataservice  
09/30/2022 15:12:11;0002;Server@mustang;Svr;Server@mustang;Starting PBS dataservice  
09/30/2022 15:12:22;0002;Server@mustang;Svr;Server@mustang;pbs\_status\_db exit code 1

Please advice me how to resolve this issue.

Thanks in advance  
CS

---

<div class="post-metadata">

**Author:** ![dtalcott](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.openpbs.org/dtalcott/32/410_2.png) [@dtalcott](https://community.openpbs.org/u/dtalcott)\
**Post date:** [October 3, 2022, 8:16pm UTC](https://community.openpbs.org/t/connection-refused-errno-15010/3298/2 "2022-10-03T20:16:08Z")

</div>

You need to figure out why the PBS database is not starting. For me, there was a permissions issue fixed by

```auto
chmod 1777 /var/run/postgresql/

```

This has to be done on every reboot before starting PBS.

---

<div class="post-metadata">

**Author:** ![eclipseye](https://avatars.discourse-cdn.com/v4/letter/e/e495f1/32.png) [@eclipseye](https://community.openpbs.org/u/eclipseye)\
**Post date:** [October 7, 2022, 12:05am UTC](https://community.openpbs.org/t/connection-refused-errno-15010/3298/3 "2022-10-07T00:05:59Z")

</div>

Thanks for the comment.  
However, it doesn’t work for me.

---

<div class="post-metadata">

**Author:** ![belanasaikiran](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.openpbs.org/belanasaikiran/32/626_2.png) [@belanasaikiran](https://community.openpbs.org/u/belanasaikiran)\
**Post date:** [February 1, 2023, 9:51am UTC](https://community.openpbs.org/t/connection-refused-errno-15010/3298/4 "2023-02-01T09:51:34Z")

</div>

Hi,

I’m facing the same errno `15010`. Just want to know if you are facing the same.

Here’s my log:

```auto
server2@ubuntu:~/openpbs/openpbs_22.05.11.ubuntu_18.04$ sudo /etc/init.d/pbs status
pbs_server is not running
pbs_mom is not running
pbs_sched is pid 4385
pbs_comm is not running

```

When I try to start or restart the service, I get the below:

```auto
server2@ubuntu:~/openpbs/openpbs_22.05.11.ubuntu_18.04$ sudo /etc/init.d/pbs restart 
Restarting PBS
Stopping PBS
PBS sched - was pid: 4385
Waiting for shutdown to complete
Starting PBS
/opt/pbs/sbin/pbs_comm ready (pid=13408), Proxy Name:ubuntu:17001, Threads:4
PBS comm
PBS mom
PBS sched
-su: 1: /etc/profile.d/10-budgie-desktop-common.sh: [[: not found
-su: 1: /etc/profile.d/10-budgie-desktop.sh: [[: not found
-su: 1: /etc/profile.d/10-budgie-desktop-common.sh: [[: not found
-su: 1: /etc/profile.d/10-budgie-desktop.sh: [[: not found
/opt/pbs/sbin/pbs_ds_systemd: 43: [: xdegraded: unexpected operator
/opt/pbs/sbin/pbs_ds_systemd: 66: /opt/pbs/sbin/pbs_ds_systemd: cannot create /sys/fs/cgroup/systemd/system.slice/pbs.service/tasks: Directory nonexistent
/opt/pbs/sbin/pbs_ds_systemd: 70: /opt/pbs/sbin/pbs_ds_systemd: cannot create /sys/fs/cgroup/systemd/system.slice/pbs.service/tasks: Directory nonexistent
/opt/pbs/sbin/pbs_ds_systemd: 70: /opt/pbs/sbin/pbs_ds_systemd: cannot create /sys/fs/cgroup/systemd/system.slice/pbs.service/tasks: Directory nonexistent
/opt/pbs/sbin/pbs_ds_systemd: 70: /opt/pbs/sbin/pbs_ds_systemd: cannot create /sys/fs/cgroup/systemd/system.slice/pbs.service/tasks: Directory nonexistent
/opt/pbs/sbin/pbs_ds_systemd: 70: /opt/pbs/sbin/pbs_ds_systemd: cannot create /sys/fs/cgroup/systemd/system.slice/pbs.service/tasks: Directory nonexistent
/opt/pbs/sbin/pbs_ds_systemd: 70: /opt/pbs/sbin/pbs_ds_systemd: cannot create /sys/fs/cgroup/systemd/system.slice/pbs.service/tasks: Directory nonexistent
/opt/pbs/sbin/pbs_ds_systemd: 70: /opt/pbs/sbin/pbs_ds_systemd: cannot create /sys/fs/cgroup/systemd/system.slice/pbs.service/tasks: Directory nonexistent
/opt/pbs/sbin/pbs_ds_systemd: 70: /opt/pbs/sbin/pbs_ds_systemd: cannot create /sys/fs/cgroup/systemd/system.slice/pbs.service/tasks: Directory nonexistent
-su: 1: /etc/profile.d/10-budgie-desktop-common.sh: [[: not found
-su: 1: /etc/profile.d/10-budgie-desktop.sh: [[: not found
Connecting to PBS dataservice...connected to PBS dataservice@ubuntu
PBS server
server2@ubuntu:~/openpbs/openpbs_22.05.11.ubuntu_18.04$ sudo /etc/init.d/pbs status
pbs_server is pid 13590
pbs_mom is not running
pbs_sched is pid 13435
pbs_comm is not running
server2@ubuntu:~/openpbs/openpbs_22.05.11.ubuntu_18.04$ sudo /etc/init.d/pbs status
pbs_server is not running
pbs_mom is not running
pbs_sched is pid 13435
pbs_comm is not running

```

Please help.

---

<div class="post-metadata">

**Author:** ![chrisseismic](https://avatars.discourse-cdn.com/v4/letter/c/e9c0ed/32.png) [@chrisseismic](https://community.openpbs.org/u/chrisseismic)\
**Post date:** [July 7, 2023, 2:48am UTC](https://community.openpbs.org/t/connection-refused-errno-15010/3298/5 "2023-07-07T02:48:20Z")

</div>

Hey I am facing the same issue and wondered if there were other solutions. I have installed openpbs on ubuntu 20.04. I have managed to get so far and now have nearly all the services running apart from the pbsserver. I had an issue with the IP, which i resolved, but now I am stuck.

The logs seem to suggest everything is okay, but doesnt start. I think thats also the reason when i run pbsnodes -a it comes back with this pbsnodes: cannot connect to server pbshost, error=15010 as the server isnt actually running.

sudo /etc/init.d/pbs status  
pbs\_server is not running  
pbs\_mom is pid 5551  
pbs\_sched is pid 5568  
pbs\_comm is 5540

07/07/2023 09:46:02;0002;Server@pbshost;Svr;Log;Log opened  
07/07/2023 09:46:02;0002;Server@pbshost;Svr;Server@pbshost;pbs\_version=23.06.06  
07/07/2023 09:46:02;0002;Server@pbshost;Svr;Server@pbshost;pbs\_build=mach=N/A:security=N/A:configure\_args=N/A  
07/07/2023 09:46:02;0002;Server@pbshost;Svr;Server@pbshost;hostname=pbshost;pbs\_leaf\_name=N/A;pbs\_mom\_node\_name=N/A  
07/07/2023 09:46:02;0002;Server@pbshost;Svr;Server@pbshost;ipv4 interface lo: ip6-loopback  
07/07/2023 09:46:02;0002;Server@pbshost;Svr;Server@pbshost;ipv4 interface enp212s0: pbshost  
07/07/2023 09:46:02;0002;Server@pbshost;Svr;Server@pbshost;ipv6 interface lo: ip6-loopback  
07/07/2023 09:46:02;0002;Server@pbshost;Svr;Server@pbshost;ipv6 interface enp212s0: pacific04  
07/07/2023 09:46:02;0002;Server@pbshost;Svr;Server@pbshost;ipv6 interface enp212s0: pacific04  
07/07/2023 09:46:02;0002;Server@pbshost;Svr;Server@pbshost;ipv6 interface enp212s0: pacific04  
07/07/2023 09:46:02;0006;Server@pbshost;Fil;Server@pbshost;Version 23.06.06, started, initialization type = 1  
07/07/2023 09:46:02;0002;Server@pbshost;Svr;Server@pbshost;pbs\_status\_db exit code 1  
07/07/2023 09:46:02;0002;Server@pbshost;Svr;Server@pbshost;Starting PBS dataservice  
07/07/2023 09:46:05;0002;Server@pbshost;Svr;Server@pbshost;connected to PBS dataservice@pbshost  
07/07/2023 09:46:05;0d80;Server@pbshost;TPP;Server@pbshost(Main Thread);TPP authentication method = resvport  
07/07/2023 09:46:05;0c06;Server@pbshost;TPP;Server@pbshost(Main Thread);TPP leaf node names = 192.168.1.221:15001,127.0.0.1:15001,192.168.1.221:15001  
07/07/2023 09:46:05;0d80;Server@pbshost;TPP;Server@pbshost(Main Thread);Initializing TPP transport Layer  
07/07/2023 09:46:05;0d80;Server@pbshost;TPP;Server@pbshost(Main Thread);Max files allowed = 16384  
07/07/2023 09:46:05;0d80;Server@pbshost;TPP;Server@pbshost(Main Thread);TPP initialization done  
07/07/2023 09:46:05;0d80;Server@pbshost;TPP;Server@pbshost(Main Thread);Connecting to pbs\_comm pbshost:17001  
07/07/2023 09:46:05;0c06;Server@pbshost;TPP;Server@pbshost(Thread 0);Thread ready  
07/07/2023 09:46:05;0c06;Server@pbshost;TPP;Server@pbshost(Thread 0);Registering address 192.168.1.221:15001 to pbs\_comm pbshost:17001  
07/07/2023 09:46:05;0c06;Server@pbshost;TPP;Server@pbshost(Thread 0);Connected to pbs\_comm pbshost:17001  
07/07/2023 09:46:05;0002;Server@pbshost;n/a;setup\_env;read environment from /var/spool/pbs/pbs\_environment  
07/07/2023 09:46:05;0000;Server@pbshost;Svr;Server@pbshost;Supported authentication method: resvport  
07/07/2023 09:46:05;0002;Server@pbshost;Svr;Server@pbshost;Stopping PBS dataservice

---

<div class="post-metadata">

**Author:** ![Aminadat](https://avatars.discourse-cdn.com/v4/letter/a/ecae2f/32.png) [@Aminadat](https://community.openpbs.org/u/Aminadat)\
**Post date:** [January 17, 2024, 6:30am UTC](https://community.openpbs.org/t/connection-refused-errno-15010/3298/6 "2024-01-17T06:30:50Z")

</div>

Hello, I have the same problem, have you still not found a solution?
