# Connection refused/qstat: cannot connect to server J35 (errno=15010)

**URL:** <https://community.openpbs.org/t/connection-refused-qstat-cannot-connect-to-server-j35-errno-15010/3275>\
**Category:** Users/Site Administrators\
**Created:** [September 12, 2022, 10:34am UTC](https://community.openpbs.org/t/connection-refused-qstat-cannot-connect-to-server-j35-errno-15010/3275 "2022-09-12T10:34:19Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![aVrise](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.openpbs.org/avrise/32/601_2.png) [@aVrise](https://community.openpbs.org/u/aVrise)\
**Post date:** [September 12, 2022, 10:34am UTC](https://community.openpbs.org/t/connection-refused-qstat-cannot-connect-to-server-j35-errno-15010/3275/1 "2022-09-12T10:34:19Z")

</div>

Hi all,

I try to install the OpenPBS on a single node for task management.

However, there is an error when I run qstat after starting PBS. Do you have any idea on my problem? Thank you!

I have disabled the firewall:  
$ firewall-cmd --state  
not running

$ grep -v ‘#’ /etc/hosts  
127.0.0.1 localhost  
10.96.44.240 J35

$ sudo /etc/init.d/pbs status  
pbs\_server is not running  
pbs\_mom is pid 11297  
pbs\_sched is pid 11310  
pbs\_comm is 11287

$ cat /etc/pbs.conf  
PBS\_SERVER=J35  
PBS\_START\_SERVER=1  
PBS\_START\_SCHED=1  
PBS\_START\_COMM=1  
PBS\_START\_MOM=1  
PBS\_EXEC=/opt/pbs  
PBS\_HOME=/var/spool/pbs  
PBS\_CORE\_LIMIT=unlimited  
PBS\_SCP=/bin/scp

---

<div class="post-metadata">

**Author:** ![adarsh](https://avatars.discourse-cdn.com/v4/letter/a/f07891/32.png) [@adarsh](https://community.openpbs.org/u/adarsh)\
**Post date:** [September 12, 2022, 11:53am UTC](https://community.openpbs.org/t/connection-refused-qstat-cannot-connect-to-server-j35-errno-15010/3275/2 "2022-09-12T11:53:24Z")

</div>

Please run the qstat command again (share us the outcome) and corresponding log in the $PBS\_HOME/server\_logs/YYYYMMDD against that command.

---

<div class="post-metadata">

**Author:** ![aVrise](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.openpbs.org/avrise/32/601_2.png) [@aVrise](https://community.openpbs.org/u/aVrise)\
**Post date:** [September 12, 2022, 3:09pm UTC](https://community.openpbs.org/t/connection-refused-qstat-cannot-connect-to-server-j35-errno-15010/3275/3 "2022-09-12T15:09:51Z")

</div>

Thanks for your reply. Here are the outputs.

$ qstat

Connection refused  
qstat: cannot connect to server J35 (errno=15010)

$ vi /var/spool/pbs/server\_logs/20220912

09/12/2022 18:27:07;0002;Server@j35;Svr;Log;Log opened  
09/12/2022 18:27:07;0002;Server@j35;Svr;Server@j35;pbs\_version=20.0.0  
09/12/2022 18:27:07;0002;Server@j35;Svr;Server@j35;pbs\_build=mach=N/A:security=N/A:configure\_args=N/A  
09/12/2022 18:27:07;0002;Server@j35;Svr;Server@j35;hostname=j35;pbs\_leaf\_name=N/A;pbs\_mom\_node\_name=N/A  
09/12/2022 18:27:07;0002;Server@j35;Svr;Server@j35;ipv4 interface lo: localhost  
09/12/2022 18:27:07;0002;Server@j35;Svr;Server@j35;ipv4 interface enp0s20f0u7u2c2: J35  
09/12/2022 18:27:07;0002;Server@j35;Svr;Server@j35;ipv4 interface eno2: J35  
09/12/2022 18:27:07;0002;Server@j35;Svr;Server@j35;ipv6 interface lo: localhost  
09/12/2022 18:27:07;0002;Server@j35;Svr;Server@j35;ipv6 interface enp0s20f0u7u2c2: J35  
09/12/2022 18:27:07;0002;Server@j35;Svr;Server@j35;ipv6 interface eno2: J35  
09/12/2022 18:27:07;0006;Server@j35;Fil;Server@j35;Version 20.0.0, started, initialization type = 1  
09/12/2022 18:27:07;0002;Server@j35;Svr;Server@j35;pbs\_status\_db exit code 1  
09/12/2022 18:27:07;0002;Server@j35;Svr;Server@j35;Starting PBS dataservice  
09/12/2022 18:27:11;0002;Server@j35;Svr;Server@j35;connected to PBS dataservice@j35  
09/12/2022 18:27:11;0d80;Server@j35;TPP;Server@j35(Main Thread);TPP authentication method = resvport  
09/12/2022 18:27:11;0c06;Server@j35;TPP;Server@j35(Main Thread);TPP leaf node names = 10.96.44.240:15001,127.0.0.1:15001,169.254.3.1:15001,10.96.44.240:15001  
09/12/2022 18:27:11;0d80;Server@j35;TPP;Server@j35(Main Thread);Initializing TPP transport Layer  
09/12/2022 18:27:11;0d80;Server@j35;TPP;Server@j35(Main Thread);Max files allowed = 16384  
09/12/2022 18:27:11;0d80;Server@j35;TPP;Server@j35(Main Thread);TPP initialization done  
09/12/2022 18:27:11;0d80;Server@j35;TPP;Server@j35(Main Thread);Connecting to pbs\_comm J35:17001  
09/12/2022 18:27:11;0c06;Server@j35;TPP;Server@j35(Thread 0);Thread ready  
09/12/2022 18:27:11;0c06;Server@j35;TPP;Server@j35(Thread 0);Registering address 10.96.44.240:15001 to pbs\_comm J35:17001  
09/12/2022 18:27:11;0c06;Server@j35;TPP;Server@j35(Thread 0);Registering address 169.254.3.1:15001 to pbs\_comm J35:17001  
09/12/2022 18:27:11;0c06;Server@j35;TPP;Server@j35(Thread 0);Connected to pbs\_comm J35:17001  
09/12/2022 18:27:11;0002;Server@j35;n/a;setup\_env;read environment from /var/spool/pbs/pbs\_environment  
09/12/2022 18:27:11;0000;Server@j35;Svr;Server@j35;Supported authentication method: resvport  
09/12/2022 18:27:11;0002;Server@j35;Svr;Server@j35;Stopping PBS dataservice

---

<div class="post-metadata">

**Author:** ![adarsh](https://avatars.discourse-cdn.com/v4/letter/a/f07891/32.png) [@adarsh](https://community.openpbs.org/u/adarsh)\
**Post date:** [September 12, 2022, 6:39pm UTC](https://community.openpbs.org/t/connection-refused-qstat-cannot-connect-to-server-j35-errno-15010/3275/4 "2022-09-12T18:39:12Z")

</div>

Please check

1. SELinux is disabled and system is restarted

2. Firewall is disabled (recheck please) and ports 15001-15009 are open for communication

3. could you please add this alias to your server IP across the complex or use lower case  
10.96.44.240 J35 j35  
or  
10.96.44.240 j35

4. please share the output of qstat -Bf

---

<div class="post-metadata">

**Author:** ![aVrise](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.openpbs.org/avrise/32/601_2.png) [@aVrise](https://community.openpbs.org/u/aVrise)\
**Post date:** [September 13, 2022, 2:30am UTC](https://community.openpbs.org/t/connection-refused-qstat-cannot-connect-to-server-j35-errno-15010/3275/5 "2022-09-13T02:30:06Z")

</div>

Hi adarsh. All set and restarted. But it still doesn’t work.

$ sestatus  
SELinux status: disabled

$ sudo firewall-cmd --state  
not running

$ sudo firewall-cmd --list-ports  
FirewallD is not running

$ sudo iptables -S  
-P INPUT ACCEPT  
-P FORWARD ACCEPT  
-P OUTPUT ACCEPT  
-A INPUT -p tcp -m tcp --dport 17001 -j ACCEPT  
-A INPUT -p tcp -m tcp --dport 15009 -j ACCEPT  
-A INPUT -p tcp -m tcp --dport 15008 -j ACCEPT  
-A INPUT -p tcp -m tcp --dport 15007 -j ACCEPT  
-A INPUT -p tcp -m tcp --dport 15006 -j ACCEPT  
-A INPUT -p tcp -m tcp --dport 15005 -j ACCEPT  
-A INPUT -p tcp -m tcp --dport 15004 -j ACCEPT  
-A INPUT -p tcp -m tcp --dport 15003 -j ACCEPT  
-A INPUT -p tcp -m tcp --dport 15002 -j ACCEPT  
-A INPUT -p tcp -m tcp --dport 15001 -j ACCEPT

$ grep -v ‘#’ /etc/hosts  
127.0.0.1 localhost  
10.96.44.240 J35 j35

$ qstat -Bf  
Connection refused  
qstat: cannot connect to server J35 (errno=15010)

$ vi /var/spool/pbs/server\_logs/20220913  
09/13/2022 10:25:14;0002;Server@j35;Svr;Log;Log opened  
09/13/2022 10:25:14;0002;Server@j35;Svr;Server@j35;pbs\_version=20.0.0  
09/13/2022 10:25:14;0002;Server@j35;Svr;Server@j35;pbs\_build=mach=N/A:security=N/A:configure\_args=N/A  
09/13/2022 10:25:14;0002;Server@j35;Svr;Server@j35;hostname=j35;pbs\_leaf\_name=N/A;pbs\_mom\_node\_name=N/A  
09/13/2022 10:25:14;0002;Server@j35;Svr;Server@j35;ipv4 interface lo: localhost  
09/13/2022 10:25:14;0002;Server@j35;Svr;Server@j35;ipv4 interface enp0s20f0u7u2c2: J35  
09/13/2022 10:25:14;0002;Server@j35;Svr;Server@j35;ipv4 interface eno2: j35  
09/13/2022 10:25:14;0002;Server@j35;Svr;Server@j35;ipv6 interface lo: localhost  
09/13/2022 10:25:14;0002;Server@j35;Svr;Server@j35;ipv6 interface enp0s20f0u7u2c2: J35  
09/13/2022 10:25:14;0002;Server@j35;Svr;Server@j35;ipv6 interface eno2: J35  
09/13/2022 10:25:14;0006;Server@j35;Fil;Server@j35;Version 20.0.0, started, initialization type = 1  
09/13/2022 10:25:14;0002;Server@j35;Svr;Server@j35;pbs\_status\_db exit code 1  
09/13/2022 10:25:14;0002;Server@j35;Svr;Server@j35;Starting PBS dataservice  
09/13/2022 10:25:17;0002;Server@j35;Svr;Server@j35;connected to PBS dataservice@j35  
09/13/2022 10:25:17;0d80;Server@j35;TPP;Server@j35(Main Thread);TPP authentication method = resvport  
09/13/2022 10:25:17;0c06;Server@j35;TPP;Server@j35(Main Thread);TPP leaf node names = 10.96.44.240:15001,127.0.0.1:15001,169.254.3.1:15001,10.96.44.240:15001  
09/13/2022 10:25:17;0d80;Server@j35;TPP;Server@j35(Main Thread);Initializing TPP transport Layer  
09/13/2022 10:25:17;0d80;Server@j35;TPP;Server@j35(Main Thread);Max files allowed = 16384  
09/13/2022 10:25:17;0d80;Server@j35;TPP;Server@j35(Main Thread);TPP initialization done  
09/13/2022 10:25:17;0d80;Server@j35;TPP;Server@j35(Main Thread);Connecting to pbs\_comm J35:17001  
09/13/2022 10:25:17;0c06;Server@j35;TPP;Server@j35(Thread 0);Thread ready  
09/13/2022 10:25:17;0c06;Server@j35;TPP;Server@j35(Thread 0);Registering address 10.96.44.240:15001 to pbs\_comm J35:17001  
09/13/2022 10:25:17;0c06;Server@j35;TPP;Server@j35(Thread 0);Registering address 169.254.3.1:15001 to pbs\_comm J35:17001  
09/13/2022 10:25:17;0c06;Server@j35;TPP;Server@j35(Thread 0);Connected to pbs\_comm J35:17001  
09/13/2022 10:25:17;0002;Server@j35;n/a;setup\_env;read environment from /var/spool/pbs/pbs\_environment  
09/13/2022 10:25:17;0000;Server@j35;Svr;Server@j35;Supported authentication method: resvport  
09/13/2022 10:25:17;0002;Server@j35;Svr;Server@j35;Stopping PBS dataservice

---

<div class="post-metadata">

**Author:** ![aVrise](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.openpbs.org/avrise/32/601_2.png) [@aVrise](https://community.openpbs.org/u/aVrise)\
**Post date:** [September 13, 2022, 2:39am UTC](https://community.openpbs.org/t/connection-refused-qstat-cannot-connect-to-server-j35-errno-15010/3275/6 "2022-09-13T02:39:08Z")

</div>

Indeed, there are some errors with ln when I $ sudo /opt/pbs/libexec/pbs\_postinstall (See below). Is this a big problem?

$ sudo /opt/pbs/libexec/pbs\_postinstall  
\*\*\* PBS Installation Summary

* * *

\*\*\* Postinstall script called as follows:  
\*\*\* /opt/pbs/libexec/pbs\_postinstall ‘’

* * *

\*\*\* Existing configuration file found: /etc/pbs.conf

* * *

\*\*\* Saving /etc/pbs.conf as /etc/pbs.conf.pre.20.0.0.20220913103220  
\*\*\* Replacing /etc/pbs.conf with /etc/pbs.conf.20.0.0  
\*\*\* /etc/pbs.conf has been modified.  
\*\*\* The original contents have been saved to /etc/pbs.conf.pre.20.0.0.20220913103220

* * *

\*\*\* Registering PBS as a service.  
ln: failed to create symbolic link ‘/etc/rc.d/rc0.d/K10pbs’: No such file or directory  
ln: failed to create symbolic link ‘/etc/rc.d/rc1.d/K10pbs’: No such file or directory  
ln: failed to create symbolic link ‘/etc/rc.d/rc2.d/K10pbs’: No such file or directory  
ln: failed to create symbolic link ‘/etc/rc.d/rc3.d/S90pbs’: No such file or directory  
ln: failed to create symbolic link ‘/etc/rc.d/rc4.d/K10pbs’: No such file or directory  
ln: failed to create symbolic link ‘/etc/rc.d/rc5.d/S90pbs’: No such file or directory  
ln: failed to create symbolic link ‘/etc/rc.d/rc6.d/K10pbs’: No such file or directory

* * *

\*\*\* PBS\_HOME is /var/spool/pbs  
\*\*\* Existing environment file left unmodified: /var/spool/pbs/pbs\_environment

* * *

\*\*\* The PBS server has been installed in /opt/pbs/sbin.  
\*\*\* The PBS scheduler has been installed in /opt/pbs/sbin.

* * *

\*\*\* The PBS communication agent has been installed in /opt/pbs/sbin.

* * *

\*\*\* The PBS MOM has been installed in /opt/pbs/sbin.

* * *

\*\*\* The PBS commands have been installed in /opt/pbs/bin.

* * *

\*\*\* End of /opt/pbs/libexec/pbs\_postinstall

Btw, the system is centos stream 9. Is there any compatible problem?

$ cat /etc/os-release  
NAME=“CentOS Stream”  
VERSION=“9”  
ID=“centos”  
ID\_LIKE=“rhel fedora”  
VERSION\_ID=“9”  
PLATFORM\_ID=“platform:el9”  
PRETTY\_NAME=“CentOS Stream 9”  
ANSI\_COLOR=“0;31”  
LOGO=“fedora-logo-icon”  
CPE\_NAME=“cpe:/o:centos:centos:9”  
HOME\_URL=“[https://centos.org/](https://centos.org/)”  
BUG\_REPORT\_URL=“[https://bugzilla.redhat.com/](https://bugzilla.redhat.com/)”  
REDHAT\_SUPPORT\_PRODUCT=“Red Hat Enterprise Linux 9”  
REDHAT\_SUPPORT\_PRODUCT\_VERSION=“CentOS Stream”

---

<div class="post-metadata">

**Author:** ![adarsh](https://avatars.discourse-cdn.com/v4/letter/a/f07891/32.png) [@adarsh](https://community.openpbs.org/u/adarsh)\
**Post date:** [September 13, 2022, 11:14am UTC](https://community.openpbs.org/t/connection-refused-qstat-cannot-connect-to-server-j35-errno-15010/3275/7 "2022-09-13T11:14:07Z")

</div>

I have not tested in on Centos stream 9. If you have compiled it by source, then it should work.  
Thanks for posting the diagnostics, members might comment on this.

---

<div class="post-metadata">

**Author:** ![aVrise](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.openpbs.org/avrise/32/601_2.png) [@aVrise](https://community.openpbs.org/u/aVrise)\
**Post date:** [September 14, 2022, 2:46am UTC](https://community.openpbs.org/t/connection-refused-qstat-cannot-connect-to-server-j35-errno-15010/3275/8 "2022-09-14T02:46:44Z")

</div>

Alright. Thank you so much!
