# Installation with two computers

**URL:** <https://community.openpbs.org/t/installation-with-two-computers/1835>\
**Category:** Users/Site Administrators\
**Created:** [October 31, 2019, 8:23pm UTC](https://community.openpbs.org/t/installation-with-two-computers/1835 "2019-10-31T20:23:46Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![ldunga77](https://avatars.discourse-cdn.com/v4/letter/l/9e8a1a/32.png) [@ldunga77](https://community.openpbs.org/u/ldunga77)\
**Post date:** [October 31, 2019, 8:23pm UTC](https://community.openpbs.org/t/installation-with-two-computers/1835/1 "2019-10-31T20:23:46Z")

</div>

I am trying to link two computers (both centos 7) using PBS for running and scheduling mpi jobs. I am using first computer as head node and also as execution node and client node. I have all the services (pbs\_comm, pbs\_mom, pbs\_sched, pbs\_server.bin) working and I can submit jobs to default queue. I have installed pbs\_execution on the second machine and verified pbs\_mom is running. Using pbs\_hostn I verified i can see server. But when I do "pbsnodes -a " i keep getting error:

No route to host  
pbsnodes: cannot connect to server manowar, error=113

Can someone tell me how to fix this?  
thanks,  
Shashi

---

<div class="post-metadata">

**Author:** ![adarsh](https://avatars.discourse-cdn.com/v4/letter/a/f07891/32.png) [@adarsh](https://community.openpbs.org/u/adarsh)\
**Post date:** [October 31, 2019, 10:00pm UTC](https://community.openpbs.org/t/installation-with-two-computers/1835/2 "2019-10-31T22:00:17Z")

</div>

**Please find this checklist on system configuration on your two computers**

1. SELinux disabled and rebooted
2. Firewalls disabled
3. Both machines have static IP address/hostnames defined and mentioned in /etc/hosts  
The contents of /etc/hosts are correct on both the systems.
4. Passsword-less SSH is configured between those two systems and to themselves( hostbased passwordless authentication or ssh keybased authentications) for all the users
5. Common home directory via NFS or Common Working directory which is readable writable and accessible by all the users across both the systems.

> [@ldunga77](#):
>
> No route to host  
> pbsnodes: cannot connect to server manowar, error=113

This might be related to

1. Network resolutions issue , check /etc/hosts
2. Check the pbs services are running systemctl status pbs

Hope this helps.

---

<div class="post-metadata">

**Author:** ![ldunga77](https://avatars.discourse-cdn.com/v4/letter/l/9e8a1a/32.png) [@ldunga77](https://community.openpbs.org/u/ldunga77)\
**Post date:** [November 1, 2019, 3:37am UTC](https://community.openpbs.org/t/installation-with-two-computers/1835/3 "2019-11-01T03:37:41Z")

</div>

Thank you. The issue was with the firewall on the server.  
Shashi
