# PBS Pro Service Will Not Start

**URL:** <https://community.openpbs.org/t/pbs-pro-service-will-not-start/1721>\
**Category:** Users/Site Administrators\
**Created:** [August 2, 2019, 4:10pm UTC](https://community.openpbs.org/t/pbs-pro-service-will-not-start/1721 "2019-08-02T16:10:40Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![rementis](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.openpbs.org/rementis/32/249_2.png) [@rementis](https://community.openpbs.org/u/rementis)\
**Post date:** [August 2, 2019, 4:10pm UTC](https://community.openpbs.org/t/pbs-pro-service-will-not-start/1721/1 "2019-08-02T16:10:40Z")

</div>

Errors in log indicate job recovery errors.

My question is, can the job queue be totally cleared manually prior to starting PBS Pro services? Just want a clean slate, and no job recoveries on startup.

Thanks in advance for any help!

---

<div class="post-metadata">

**Author:** ![adarsh](https://avatars.discourse-cdn.com/v4/letter/a/f07891/32.png) [@adarsh](https://community.openpbs.org/u/adarsh)\
**Post date:** [August 3, 2019, 8:37am UTC](https://community.openpbs.org/t/pbs-pro-service-will-not-start/1721/2 "2019-08-03T08:37:19Z")

</div>

Yes, you can do by truncating the tables containing the jobs in the pbs datastore

1. Stop PBS services
2. Start pbs\_dataservice
3. connect to database
4. truncate the tables related to jobs
5. disconnect from the database
6. start the PBS Services  
All jobs from this history and queue will be cleared .

Hope this helps.
