# Pbs\_server not running

**URL:** <https://community.openpbs.org/t/pbs-server-not-running/3307>\
**Category:** Users/Site Administrators\
**Created:** [October 10, 2022, 6:23am UTC](https://community.openpbs.org/t/pbs-server-not-running/3307 "2022-10-10T06:23:55Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![WBFF96](https://avatars.discourse-cdn.com/v4/letter/w/82dd89/32.png) [@WBFF96](https://community.openpbs.org/u/WBFF96)\
**Post date:** [October 10, 2022, 6:23am UTC](https://community.openpbs.org/t/pbs-server-not-running/3307/1 "2022-10-10T06:23:55Z")

</div>

Hello, I installed openpbs-22.05.11 from source on centos7.6，The compilation parameters are ./configure --with-pmix=/opt/hpc/software/mpi/pmix --with-python=/opt/python3.9 --with-pbs-server-home=/var/spool/pbs --with-database-dir=/opt/postgresql14 --prefix=/opt/pbs  
When the installation is complete and the service is started with “systemctl restart pbs”, an error is reported in the /var/spool/pbs/server\_logs/20221010 log file:  
10/10/2022 14:11:50;0002;Server@g09r4n07;Svr;Server@g09r4n07;Starting PBS dataservice  
10/10/2022 14:11:53;0002;Server@g09r4n07;Svr;Server@g09r4n07;pbs\_status\_db exit code 0  
10/10/2022 14:11:54;0002;Server@g09r4n07;Svr;Server@g09r4n07;Prepare of statement insert\_job failed: ERROR: relation “pbs.job” does not exist  
LINE 1: insert into pbs.job (ji\_jobid,ji\_state,ji\_substate,ji\_svrfla…  
^ 42P01

[root@g09r4n07 server\_logs]# ps -ef | grep pbs  
root 9741 1 0 14:18 ? 00:00:00 /opt/pbs/sbin/pbs\_comm  
root 9753 1 0 14:18 ? 00:00:00 /opt/pbs/sbin/pbs\_mom  
root 9768 1 0 14:18 ? 00:00:00 /opt/pbs/sbin/pbs\_sched  
root 12893 1 0 14:19 ? 00:00:00 /opt/pbs/sbin/pbs\_server.bin  
root 12896 1 0 14:19 ? 00:00:00 /opt/pbs/sbin/pbs\_ds\_monitor monitor  
postgres 12960 1 1 14:19 ? 00:00:00 /usr/bin/postgres -D /var/spool/pbs/datastore -p 15007  
root 12984 17602 0 14:19 pts/4 00:00:00 grep --color=auto pb

how should i do to start the pbs\_server?

---

<div class="post-metadata">

**Author:** ![WBFF96](https://avatars.discourse-cdn.com/v4/letter/w/82dd89/32.png) [@WBFF96](https://community.openpbs.org/u/WBFF96)\
**Post date:** [October 13, 2022, 1:58am UTC](https://community.openpbs.org/t/pbs-server-not-running/3307/2 "2022-10-13T01:58:55Z")

</div>

This problem has been solved.
