# Problems install and running PBS on Ubuntu 18

**URL:** <https://community.openpbs.org/t/problems-install-and-running-pbs-on-ubuntu-18/2255>\
**Category:** Users/Site Administrators\
**Created:** [August 28, 2020, 7:02am UTC](https://community.openpbs.org/t/problems-install-and-running-pbs-on-ubuntu-18/2255 "2020-08-28T07:02:25Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![rudy](https://avatars.discourse-cdn.com/v4/letter/r/5fc32e/32.png) [@rudy](https://community.openpbs.org/u/rudy)\
**Post date:** [August 28, 2020, 7:02am UTC](https://community.openpbs.org/t/problems-install-and-running-pbs-on-ubuntu-18/2255/1 "2020-08-28T07:02:25Z")

</div>

Hi @ all,

I’m new on using OpenPBS. I finally want to install and run it on a small Cluster, but at present I’m trying to get it run on a single node and it fails everytime. I installed OpenPBS 20 (openpbs-master) following the guidelines in [https://github.com/openpbs/openpbs/blob/master/INSTALL](https://github.com/openpbs/openpbs/blob/master/INSTALL) .

At present I got:

dy@master:~$ sudo /etc/init.d/pbs status  
[sudo] Passwort für dy:  
pbs\_server is pid 10123  
pbs\_mom is pid 2003  
pbs\_sched is pid 2019  
pbs\_comm is 1955

dy@master:~$ sudo /etc/init.d/pbs restart  
Restarting PBS  
Stopping PBS  
PBS mom - was pid: 2003  
PBS sched - was pid: 2019  
PBS comm - was pid: 1955  
Waiting for shutdown to complete  
Starting PBS  
/opt/pbs/sbin/pbs\_comm ready (pid=10972), Proxy Name:master.local:17001, Threads:4  
PBS comm  
PBS mom  
PBS sched  
PBS Server already running.

dy@master:~$ ps -ef | grep pbs  
postgres 4536 1477 0 07:33 ? 00:00:00 postgres: 12/main: postgres pbs 127.0.0.1(40892) idle  
root 10752 1 0 08:33 ? 00:00:00 /opt/pbs/sbin/pbs\_server.bin  
root 10972 1676 0 08:33 ? 00:00:00 /opt/pbs/sbin/pbs\_comm  
root 10991 1676 0 08:33 ? 00:00:00 /opt/pbs/sbin/pbs\_mom  
root 11004 1676 0 08:33 ? 00:00:00 /opt/pbs/sbin/pbs\_sched

The files:

cat /etc/pbs.conf  
PBS\_SERVER=master  
PBS\_START\_SERVER=1  
PBS\_START\_SCHED=1  
PBS\_START\_COMM=1  
PBS\_START\_MOM=1  
PBS\_EXEC=/opt/pbs  
PBS\_HOME=/var/spool/pbs  
PBS\_CORE\_LIMIT=unlimited  
PBS\_SCP=/usr/bin/scp

cat /etc/hosts  
127.0.0.1 localhost  
#127.0.1.1 dy-HP-350-G2  
100.200.10.1 master.local master  
100.200.10.2 master1.local master1

# The following lines are desirable for IPv6 capable hosts

::1 ip6-localhost ip6-loopback  
fe00::0 ip6-localnet  
ff00::0 ip6-mcastprefix  
ff02::1 ip6-allnodes  
ff02::2 ip6-allrouters

The Logfiles from server\_logs reports:

08/28/2020 00:00:39;0002;Server@master;Svr;Server@master;Failed to connect to PBS dataservice  
08/28/2020 07:20:48;0002;Server@master;Svr;Log;Log opened  
08/28/2020 07:20:48;0002;Server@master;Svr;Server@master;pbs\_version=20.0.0  
08/28/2020 07:20:48;0002;Server@master;Svr;Server@master;pbs\_build=mach=N/A:security=N/A:configure\_args=N/A  
08/28/2020 07:20:48;0002;Server@master;Svr;Server@master;hostname=master.local;pbs\_leaf\_name=N/A;pbs\_mom\_node\_name=N/A  
08/28/2020 07:20:48;0002;Server@master;Svr;Server@master;ipv4 interface lo: localhost  
08/28/2020 07:20:48;0002;Server@master;Svr;Server@master;ipv4 interface wlp2s0: localhost  
08/28/2020 07:20:48;0002;Server@master;Svr;Server@master;ipv6 interface lo: ip6-loopback  
08/28/2020 07:20:48;0002;Server@master;Svr;Server@master;ipv6 interface wlp2s0: master  
08/28/2020 07:20:48;0006;Server@master;Fil;Server@master;Version 20.0.0, started, initialization type = 1  
08/28/2020 07:20:50;0002;Server@master;Svr;Server@master;pbs\_status\_db exit code 1  
08/28/2020 07:20:50;0002;Server@master;Svr;Server@master;Starting PBS dataservice  
08/28/2020 07:23:03;0002;Server@master;Svr;Server@master;Failed to connect to PBS dataservice  
08/28/2020 07:23:04;0002;Server@master;Svr;Server@master;Starting PBS dataservice  
08/28/2020 07:23:06;0002;Server@master;Svr;Server@master;pbs\_status\_db exit code 0

and mom\_logs:

08/28/2020 07:20:47;0002;pbs\_mom;Svr;Log;Log opened  
08/28/2020 07:20:47;0002;pbs\_mom;Svr;pbs\_mom;pbs\_version=20.0.0  
08/28/2020 07:20:47;0002;pbs\_mom;Svr;pbs\_mom;pbs\_build=mach=N/A:security=N/A:configure\_args=N/A  
08/28/2020 07:20:47;0002;pbs\_mom;Svr;pbs\_mom;hostname=master.local;pbs\_leaf\_name=N/A;pbs\_mom\_node\_name=N/A  
08/28/2020 07:20:47;0002;pbs\_mom;Svr;pbs\_mom;ipv4 interface lo: localhost  
08/28/2020 07:20:47;0002;pbs\_mom;Svr;pbs\_mom;ipv4 interface wlp2s0: localhost  
08/28/2020 07:20:47;0002;pbs\_mom;Svr;pbs\_mom;ipv6 interface lo: ip6-loopback  
08/28/2020 07:20:47;0002;pbs\_mom;Svr;pbs\_mom;ipv6 interface wlp2s0: master  
08/28/2020 07:20:47;0100;pbs\_mom;Svr;parse\_config;file config  
08/28/2020 07:20:47;0002;pbs\_mom;Svr;pbs\_mom;Adding IP address 100.200.10.1 as authorized  
08/28/2020 07:20:47;0002;pbs\_mom;n/a;set\_restrict\_user\_maxsys;setting 999  
08/28/2020 07:20:47;0002;pbs\_mom;n/a;read\_config;max\_check\_poll = 120, min\_check\_poll = 10  
08/28/2020 07:20:47;0d80;pbs\_mom;TPP;pbs\_mom(Main Thread);TPP authentication method = resvport  
08/28/2020 07:20:47;0c06;pbs\_mom;TPP;pbs\_mom(Main Thread);TPP leaf node names = 100.200.10.1:15003,127.0.0.1:15003,192.168.2.106:15003  
08/28/2020 07:20:47;0d80;pbs\_mom;TPP;pbs\_mom(Main Thread);Initializing TPP transport Layer  
08/28/2020 07:20:47;0d80;pbs\_mom;TPP;pbs\_mom(Main Thread);Max files allowed = 16384  
08/28/2020 07:20:47;0d80;pbs\_mom;TPP;pbs\_mom(Main Thread);TPP initialization done  
08/28/2020 07:20:47;0c06;pbs\_mom;TPP;pbs\_mom(Main Thread);Single pbs\_comm configured, TPP Fault tolerant mode disabled  
08/28/2020 07:20:47;0d80;pbs\_mom;TPP;pbs\_mom(Main Thread);Connecting to pbs\_comm master:17001  
08/28/2020 07:20:47;0c06;pbs\_mom;TPP;pbs\_mom(Thread 0);Thread ready  
08/28/2020 07:20:47;0002;pbs\_mom;Svr;pbs\_mom;Adding IP address 127.0.0.1 as authorized  
08/28/2020 07:20:47;0002;pbs\_mom;Svr;set\_checkpoint\_path;Using default checkpoint path.  
08/28/2020 07:20:47;0002;pbs\_mom;Svr;set\_checkpoint\_path;Setting checkpoint path to /var/spool/pbs/checkpoint/  
08/28/2020 07:20:49;0002;pbs\_mom;n/a;ncpus;hyperthreading enabled  
08/28/2020 07:20:49;0002;pbs\_mom;n/a;initialize;pcpus=4, OS reports 4 cpu(s)  
08/28/2020 07:20:49;0006;pbs\_mom;Fil;pbs\_mom;Version 20.0.0, started, initialization type = 0  
08/28/2020 07:20:49;0002;pbs\_mom;Svr;pbs\_mom;Mom pid = 2003 ready, using ports Server:15001 MOM:15002 RM:15003  
08/28/2020 07:20:49;0001;pbs\_mom;Svr;pbs\_mom;Success (0) in pbs\_mom, Failed to send HELLO at master:15001

I checked /var/spool/pbs/spool/ and found db error files containing the server is not running. But it is. I got the database pbs\_datastore including scheme pbs and tables.

Running commands like qstat, qmgr fail, seams like hanging up. I got no response from the system.

Firewall is disabled - generally disabled by default, but I checked it. SELinux is not found on the system. I figured out that it might be not installed by the OS at the beginning. According to this I assume this disabled.

The OS I use is Linux Mint 19.2, which is equivalent to Ubuntu 18. The database is a postgresql 12.

I checked the forum hoping to find someone experiencing the same problems and allready tried installation using data service user pbsdata as well, but it didn’t work. I also tried ./configure --with-database-dir / database-user which fails. I know sometimes I got the response “cannot connect to server (errorno=111)” or (errorno=113) when using a command. But that happens when some of the services are not running. Presently it seems that they are not communicating to each other and I don’t know why.

I hope someone can help.  
Many thanks

Sebastian

---

<div class="post-metadata">

**Author:** ![subhasisb](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.openpbs.org/subhasisb/32/12_2.png) [@subhasisb](https://community.openpbs.org/u/subhasisb)\
**Post date:** [September 8, 2020, 5:32am UTC](https://community.openpbs.org/t/problems-install-and-running-pbs-on-ubuntu-18/2255/2 "2020-09-08T05:32:30Z")

</div>

can you enable the postgres logs and check if anything in particular is logged. You can enable postgres client side logging to get better details. How did you install postgres? Check that the postgresql-contrib package is actually installed and the hstore module was installed as well (pbs uses this). you might also want to disable firewalls, flush iptables, and check that the postgres user is available and can be su’ed into.

Another thing u could do is running the postinstall by hand, in debug mode, as follows:  
rm -rf /opt/pbs /var/spool/pbs  
make install  
sh -x /opt/pbs/libexec/pbs\_postinstall

If you find pbs\_habitat failing inside this, you can add a sh -x to that script as well to see what is going on.
