All cores submitted in one node of PBS queue

Hello,

I use Workbench of Ansys then we try to submit job for PBS queue via Ansys RSM.

We would like to submit the job for PBS queue of multi node but all cores was submitted for one node.

We set the following argument of RSM Configuration to submit for 17 nodes per 24 cores.

-l select=27:ncpus=24:mpiprocs=24

But the job was submitted for 408 cores in only one node then the job was not submitted for multi nodes.

Could you let me know how to submit the job for multi nodes?

Best regards,

Please add this line to the the RSM configuration file for PBS Pro
#PBS -l place=scatter

So that
-l select=27:ncpus=24:mpiprocs=24 would need 27 compute nodes to run (each with respective chunk)

Hello,

Thank you for your reply.

But I encountered the following error.

qsub: submit error (Unknown resource type Resource_List.place)
External operation: ‘submit’ has failed. This may or may not become a fatal error
qsub: submit error (Unknown resource type Resource_List.place)
Failed to submit job to cluster

Do you have any solution?

Best regards,

Would it be possible to share the filename and file that was updated ?
Also please share the version of PBS Pro used .

Please note directly you can run Ansys via PBS Script.
Reference:https://www.unisq.edu.au/-/media/usq/current-students/academic/research/conducting-research/eresearch-services/hpc/pbs-ansys_31_5.ashx?la=en&hash=2aea590ca47a3ebc914909ea899ff3ec

Also, you would need to check with the Application (RSM) Vendor support team about the issue ?

Could you please try to run this qsub command in a terminal and share us the output.

qstat --version 
qsub -l select=2:ncpus=1 -l place=scatter -- /bin/sleep 100
qstat -answ1

Hello,

Thank you for your reply.

I got the following command result.

[user1@host1 ~]$ qstat --version

Version: 6.1.2

[user1@host1 ~]$ qsub -l select=2:ncpus=1 -l place=scatter – /bin/sleep 100

qsub: script file ‘100’ cannot be loaded - No such file or directory

[user1@host1 ~]$ qstat -answ1

qstat: invalid option – ‘w’

usage:

                      qstat [-f [-1]] [-W site_specific] [-x] [ job_identifier... | destination... ]

                      qstat [-a|-i|-r|-e] [-u user] [-n [-1]] [-s] [-t] [-G|-M] [-R] [job_id... | destination...]

                      qstat -Q [-f [-1]] [-W site_specific] [ destination... ]

                      qstat -q [-G|-M] [ destination... ]

                      qstat -B [-f [-1]] [-W site_specific] [ server_name... ]

                      qstat -t

[user1@host1 ~]$

Thank you Alex for the above information. As you might have figured it out, that you are not running openPBS , but probably running a different scheduler.
FYI: PBS Default number of nodes and number of cpus - #4 by scott