Command"make dist" error when bulid the rmp package

Hi, everyone

I try to install the pbs, when I build the rmp packages, encounter an issue, the error info like below:

make[3]: Leaving directory /home/linux/pbspro-release_14_1_branch/src/server' (cd scheduler && make top_distdir=../../pbspro-14.1.0 distdir=../../pbspro-14.1.0/src/scheduler \ am__remove_distdir=: am__skip_length_check=: am__skip_mode_fix=: distdir) make[3]: Entering directory/home/linux/pbspro-release_14_1_branch/src/scheduler’
make[3]: Leaving directory /home/linux/pbspro-release_14_1_branch/src/scheduler' (cd modules && make top_distdir=../../pbspro-14.1.0 distdir=../../pbspro-14.1.0/src/modules \ am__remove_distdir=: am__skip_length_check=: am__skip_mode_fix=: distdir) make[3]: Entering directory/home/linux/pbspro-release_14_1_branch/src/modules’
(cd python && make top_distdir=…/…/…/pbspro-14.1.0 distdir=…/…/…/pbspro-14.1.0/src/modules/python
am__remove_distdir=: am__skip_length_check=: am__skip_mode_fix=: distdir)
make[4]: Entering directory /home/linux/pbspro-release_14_1_branch/src/modules/python' make[4]: Leaving directory/home/linux/pbspro-release_14_1_branch/src/modules/python’
make[3]: Leaving directory /home/linux/pbspro-release_14_1_branch/src/modules' (cd resmom && make top_distdir=../../pbspro-14.1.0 distdir=../../pbspro-14.1.0/src/resmom \ am__remove_distdir=: am__skip_length_check=: am__skip_mode_fix=: distdir) make[3]: Entering directory/home/linux/pbspro-release_14_1_branch/src/resmom’
make[3]: *** No rule to make target /mom_mach.c', needed bydistdir’. Stop.
make[3]: Leaving directory /home/linux/pbspro-release_14_1_branch/src/resmom' make[2]: *** [distdir] Error 1 make[2]: Leaving directory/home/linux/pbspro-release_14_1_branch/src’
make[1]: *** [distdir] Error 1
make[1]: Leaving directory `/home/linux/pbspro-release_14_1_branch’
make: *** [dist] Error 2

Please some one can take a look and give some advice:sob::sob:

I just serached the website, its said this error because of lacking the “mom_mach.c” file, so I checked, it indeed missing this file …

You said:

Are you trying to install rpm packages that you built yourself? If so, what configure options did you use? What platform are you trying to build on (“uname -a”, “cat /etc/release”)?

What was the exact command you ran that led to that make error?

If you are actually building from 14.1 source rather than the master branch (to get all of the latest check-ins) on Centos 7 or OpenSUSE 13, then why not use the prebuilt rpm packages at ?

Here’s the link to the released 14.1 source code bundle:

It’s very important that you use this source code.

1 Like

Thanks very much for your replying,mkaro.
This package works perfect well

Thanks very much for your replying,scc.

I’ve already tried the master branch, it countered the same error, so I tried the release_14_1_branch again…
I follow the instructions here “”

The platform is CentOS7, the sys info like this:

[root@centos-master etc]# uname -a
Linux centos-master.novalocal 3.10.0-327.22.2.el7.x86_64 #1 SMP Thu Jun 23 17:05:11 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

[root@centos-master etc]# cat /etc/os-release
NAME="CentOS Linux"
VERSION="7 (Core)"
ID_LIKE="rhel fedora"
PRETTY_NAME="CentOS Linux 7 (Core)"