Qsig -s suspend don't release flexlm ressources (no TSTP signal detected)

Hello -

I looked at https://github.com/PBSPro/pbspro/search?p=2&q=qsig&type=&utf8=✓ but could not figure out what’s happening when I run qsig -s <suspend/resume>?

If I run qsig -s suspend, my jobs goes to a ‘T’ state on the exec nodes, is correctly seen as ‘S’ on PBS but my flexlm licenses are not released correctly.

To release my licenses, I need to run a qsig -s TSTP (and -s CONT to resume). When doing that my job goes into a ‘S’ state on the exec nodes, but PBS still consider my job to be on ‘R’ state.

So my questions are:

What exactly qsig -s suspend/resume is doing?
Why PBS still consider my job to be running when I submit a TSTP?
Can I change the default behavior of qsig -s suspend?

Thanks !

Please check the PBS Pro reference guide for this mom config parameter $suspendsig

An fyi, the only way I could make $suspendsig work is by specifying the signals by number and not name


$suspendsig 20 18

and not