Qsub interactive job does not limit ncpu

Hi,

New to openpbs and just setup a pbs server with one pbs node. It took a while for me to figure out opening the ephemeral ports for interactive jobs to work.

My pbs node has ‘resources_available.ncpus = 256’.

When I try ‘qsub -I -l nodes=1:ppn=8’ I get the command prompt for the pbs worker node.
However, nproc shows 256.

Do interactive job automatically give you the resources for an entire node? Is it possible for 2 different users to have an interactive job on the same worker node sharing the resources (ie: CPUs or Mem)?

Thanks!

Please use the new syntax
qsub -I -l select=1:ncpus=8 <hit return>
check the output qstat -fx <of this jobid in another terminal> and qstat -answ1

The resource request via qsub for is for the scheduler to find a resource that can satisfy that request.
It would not restrict the user to user 8 cpu cores. If you would like to restrict then you would have to go through advance approach of PBS with Cgroups.

Yes, by default

Thank you for taking time to answer my questions.

Your answers are very helpful and informative! I will try your commands and I’ll try the Cgroups later at work!

1 Like

I read up on how to use cgroups with openpbs and added this to the pbs_cgroups.json and qmgr -c “import hook pbs_cgroups application/x-config default pbs_cgroups.json”

“cpu” : {
“enabled” : true,
“exclude_hosts” : ,
“exclude_vntypes” : ,
“enforce_per_period_quotas” : true
},

When I qsub -I -l select=1:ncpus=8, nproc still shows 256.
I ran stress -c 16 -t 60 and in top, I see 16 cpu threads go to 100% instead of 8.

Am I missing something?

Thanks!