Set or not set PBS_LEAF_NAME parameter

Hi,
I am not sure do I need use PBS_LEAF_NAME parameter.
In installation guide at 4.4.5 is wrote:
By default, the name of the endpoint’s host is the hostname of the machine. You can set the name where an end-point runs. This is useful when you have multiple networks configured, and you want PBS to use a particular network.

I have multiple interfaces configured.
I want to PBS using one of my particular internal network,
but my hostname resolve that particular internal network IP adress in /etc/hosts.
So do I really need set PBS_LEAF_NAME parameter in this case?
Regards!

The value of PBS_LEAF_NAME should be the hostname of the interface over which you want PBS Pro to communicate. Unless you have multiple NICs, you should not need to set this value at all.

No, if in case it uses different one , other than the one you are interested in , then you have to use PBS_LEAF_NAME.

How to check which interface PBS use to communicate? Is this information is in some log file or I should use some additional tool, to check it?

Increase the log level of all the PBS daemons server, scheduler, mom and comm(no log level , default log lever should do) and check respective logs files in $PBS_HOME.

OK, I was testing my old configuration. I reading communication log in $PBS_HOME/comm_logs .

/etc/hosts
10.10.10.1 h1.domain h1 comm_h1

pbs.conf
PBS_SERVER=h1.domain
PBS_LEAF_NAME=comm_h1

In above settings, communication deamon threads registered via this hostname and in internal network:
Comm@comm_h1
and witch nodes IPs from internal network: 10.10.10.0/24 .
But when I comment PBS_LEAF_NAME parameter in pbs.conf:
pbs.conf
PBS_SERVER=h1.domain
#PBS_LEAF_NAME=comm_h1

communication deamon threads was registered via short hostname h1:
Comm@h1
and registered communication under all networks - external too.

So, now I know, that I should use PBS_LEAF_NAME instead of just my hostname, because my hostname resolves every networks in my machine and PBS_LEAF_NAME (comm_h1) resolves just one network despite they are both in one line in /etc/hosts:
10.10.10.1 h1.domain h1 comm_h1

Thanks for help,
Regards!

It is preferable to use short hostname for the PBS_SERVER, also the jobid would be 1.h1 , instead of 1.h1.domain.

Please experiment your setup without PBS_LEAF_NAME first, if there are any issues and you could see that in the logs, then use PBS_LEAF_NAME.

Thank you

@adarsh How to increase log levels ?
I have problem with communication between server and nodes.

Server log level:
qmgr : set server log_events=2047 # make sure you revert it back to 511

Scheduler log level:

Mom log level:

  1. source /etc/pbs.conf
  2. cd $PBS_HOME/mom_priv
  3. edit config and add the below line
    $logevent 0xffffffff
  4. restart the pbs services on the compute node.

From the PBS Professional Admin guide AG-536

1 Like