Change server_host in Qmgr

I’m using Ansys Fluent 21.2 on a cluster and use PBS.
Since we need to move to Ubuntu (from CentOS), I need to recompile. Everything works fine, but…
Connection issues.
When I was checking the configs, I found the following odd thing:
Running qmgr -c “list server”:

Server tst1sjbox
server_state = Active
server_host =
scheduling = True
total_jobs = 20
state_count = Transit:0 Queued:0 Held:0 Waiting:0 Running:0 Exiting:0 Begun:0
managers = @*
operators = n@*
default_queue = workq
log_events = 511
mailer = /usr/sbin/sendmail
mail_from = adm
query_other_jobs = True
resources_default.ncpus = 1
default_chunk.ncpus = 1
scheduler_iteration = 600
flatuid = True
resv_enable = True
node_fail_requeue = 310
max_array_size = 10000
pbs_license_min = 0
pbs_license_max = 2147483647
pbs_license_linger_time = 31536000
license_count = Avail_Global:1000000 Avail_Local:1000000 Used:0 High_Use:0
pbs_version = 20.0.0
eligible_time_enable = False
job_history_enable = True
max_concurrent_provision = 5
power_provisioning = False
max_job_sequence_id = 9999999

The problem: my server_host is invalid. It should be
(ubuntuheadv3 is the original name of the image creation.)
How can I change this server_host entry?

I tried “set server tst1sjbox” but that just returns, that I don’t have enough privileges (while I’m running qmgr as root).

When I start a job from Fluent (via Windows GUI) the jobs are started on the nodes, but the connection times out. (MPT Connection Timeout).

You cannot change this value via qmgr.
what is the output of hostname command on the PBS Server host ?
Also please share the /etc/hosts contents against he PBS Server host

Even with privileges this cannot be changed using qmgr


The /etc/hosts file is default (no entries in there but localhost)
I moved the datastore to a backup location and reinstalled the PBS. That worked. I suppose the post-install script is taking care of the postgresql entry server_host.
I only have to solve the mpt_connect timeout issue.

Please make sure PBS Server host and Compute node hosts have a static IP and hostname.
Do not use the loopback address . Also, please make sure that these static IPs and hostnames are part of /etc/hosts file and are the same across server and compute nodes.

Well, the hosts file is equal on all head/ and compute nodes and contain the static IP’s and hostnames.
The Jobs are running. Qstat reports running time and the processes are visible on the compute nodes using 100% cpu.
My guess that there’s something wrong with the reporting from PBS to the client (ANSYS).
No firewall is installed but it looks like it’s a one-way direction.
But I will start/use another topic for that.
Appearantly the server_hostname cannot be changed during runtime easily.

Thanks for the help.