Installation on centos 7


I am new to here and trying to install PBS pro on a system that consists of a head node and 26 compute nodes. Now I am dealing with only two nodes for testing.

I have tried about tens of times to install PBS pro 19.1.1 right after installing centOS 7.6.1810 (Core) minimal.
Following “INSTALL” file in the source code, I installed prerequisite packages and installed PBS pro without other actions.

After installing pbspro-server and starting PBS pro, I always receive the error,

initdb: could not access directory “/var/spool/pbs/datastore”: Permission denied.

I checked that postgresql, postgresql-server, postgresql-contrib are installed.
In other case, when I installed postgresql95 (higher version), I receive an error

*** Error initializing the PBS dataservice
Error details:
/bin exists, binaries missing…exiting

Could someone help me how to install PBS pro from the start?

Thank you.


It could be permission issue related to selinux security !

Cloud you please try running /opt/pbs/libexec/pbs_habitat manually (as root user), prior that, just delete your <PBS_HOME> dir, (say /var/spool/pbs).


Thank you.

As you commented, I run pbs_habitat manually and it worked!

Now I would like to try detailed setup.

S. Hong