Mpid: Cannot set work directory: No such file or directory

When I used pbs to run an abaqus job, it told me an error in .out file

  1. Please try to run the abaqus batch commandline on its own (not with the scheduler) and find out whether it runs as expected.
  2. if 1 is successful then , compose this as a pbs script and submit the job


When I run the abaqus job on its own on bash, it works
/opt/software/abaqus/Commands/abq6144 job=bend int cpus=2 mp_mode=mpi

I set the /var/tmp to a NFS share document, the problem has been solved.
But this is very strange, it shouldn’t be the root cause.

1 Like

/var/tmp needs to be shared for your MPI job , the compute nodes need to have access to the data that it needs to work on. If it was not shared (NFS), then only one node could see the data.

By the way, I found that pbs does not update the .out file in real time. How can I do this?
I use the following approach, but it clears the .out file at the end (when the job ends)
/usr/abaqus/abaqus/6.14-4/code/bin/abq6144 job=bend int cpus=4 mp_mode=mpi >> abaqus_mpi.out

Please check this discussion

#PBS -k oed
Thanks, It can solve problem

1 Like