Qdel Unknown Job ID

Hi all,

Not a work-stopping problem, but I have openpbs-server-ohpc 20.0.1-8.2 installed and it has a job that is stuck in “Q” state and trying to remove it in a myriad of ways results in “qdel: Unknown Job Id xx.xxxx”

I believe this is because while I was testing the new cluster I reinstalled the test node that the job was assigned to (or something along those lines, I’m not too familiar with terminology yet). DNS resolution works, I’m able to delete or view other jobs by their ID now that we’re running, but this one job from the testing phase seems stuck with us forever. Is it possible to delete it somehow in a database on the head node?

Thanks for the help.

Please try the below:

qdel -W force jobid
e.g., qdel -W force 101

If the above command delete the job from the list, otherwise
restart the PBS Server:
qterm -t quick ; /etc/init.d/pbs start

Hi Adarsh,

Thanks for the comment. I have tried that command already, as well as restarting the pbs service and the entire head server itself, nothing has been able to clear this job.

I believe it’s because of the reinstallation, so I think I’m looking for a lower level way to remove this.

Thank you, alright:

  1. remove it from the postgres db or
  2. re-install

Thanks! removing it from the pbs.job database and restarting pbs worked.