Reservations - am I doing it right?

Hi, I’ve been asked to create two reservations and I’d just like to check I’m doing this correctly? I built these from the man page

pbs_rsub -R 1000 -E 1200 -G CSTUDENT -l nodes=k235,k236 -r "FREQ=WEEKLY; COUNT=52; BYDAY=TU" -N "Chem Students Tues" 
pbs_rsub -R 0900 -E 1600 -G CSTUDENT -l nodes=k235,k236 -r "FREQ=WEEKLY; COUNT=52; BYDAY=FR" -N "Chem Students Fri"

I did some searching, and came up with a post that seemed to suggest creating (a) special resource group(s) and another was a post that recommended Qlists - I don’t know what qlists are, but both seems like a level of abstraction/obfuscation too far?

My concern is that this SO post suggests that my syntax wont work and I’ll need to use something like

pbs_rsub -R 1000 -E 1200 -G CSTUD -l select=1:host=k235+1:host=k236 -r "FREQ=WEEKLY; COUNT=52; BYDAY=TU" -N "Chem Students Tues" 
pbs_rsub -R 0900 -E 1600 -G CSTUD -l select=1:host=k235+1:host=k236 -r "FREQ=WEEKLY; COUNT=52; BYDAY=FR" -N "Chem Students Fri"

But that syntax seems confusing - surely I can just list the nodes I want in the reservation?

Also, is -l place=exclhost necessary in this situation?

OK, so first, the syntax above doesn’t work because the name flag -N doesn’t take quoted strings, only a single white space delimited word. So

-N "Chem Students Tues"

becomes

-N Chem_Students_Tues

And for some reason I get the error pbs_rsub: Bad effective UID for reservation so I’ve done something else wrong as well.

Looks like the error was because I ran the pbs_rsub request as root instead of as a user account?

Running it as a user seems to have worked.

Back up. Running as a user has set the reservation. In which I discover that the nodes=<nodename> syntax means I’ve got a reservation with 1ncpu and 1GB RAM. So, no, that syntax doesn’t work.

The contemporary documentation isn’t really clear about this, but I’ve found some torque docs from moons ago that explains that every resource needs to be explicitly stated, confirming the SO post in the original question.

I never did test this. I will do once I have my urgent reservations in place using syntax I think works.

Now I’m really confused. I’ve fixed my original pbs_rsub to look like this, including the timezone.


PBS_TZID=Australia/Sydney pbs_rsub -N Chemistry_Students_Friday -R 0900 -E 1600 -r "FREQ=WEEKLY;BYDAY=FR" -G CSTUDENT -l select=1:host=k235:ncpus=22:mem=120GB+1:host=k236:ncpus=22:mem=120GB 

And I’m getting the error

pbs_rsub: Bad time specification(s)

Despite the documentation clearly showing that the format required is -R for start time in 24 hour format and -E for end in 24 hour format:

pbs_rsub -R 0800 -E 1000

What have I done wrong?

According to the documented errors (UG-145 or 1691 in the Big Book) “pbs_rsub: Bad time specification(s)” means:

Problem with the start and/or end time of the reservation, such as:
• Given start time is earlier than current date and time
• Missing start time or end time
• End time is earlier than start time

None of which are true here.

are you submitting the reservation in between 0900 and 1600? If you are, ical will convert 0900 to tomorrow’s 9am, and the reservation submission fails because the start time is past the endtime.
To get around this, you can use the datetime format, like so:

PBS_TZID=America/Los_Angeles pbs_rsub -R 202009250900 -E 202009251600  -l select=1:host=shecil+1:host=shecil -r "FREQ=WEEKLY;COUNT=52;BYDAY=FR" -N"ChemStudentsFri"
1 Like

Thank you for the clarification. This represents a distinct failure in documentation.