Selecting node hardware by queue


I have several nodes with specific hardware, namely Infiniband. I want all MPI jobs to only be sent to these nodes. To this end, I defined a custom boolean resource “ib”, flag “h”, and set it to true on all these nodes (and false on the others). Also added it to the “resources:” line in sched_config. Indeed, as long as I submit a job with ib=True it lands on one of the specific nodes.

My next step was to make a dedicated “mpi” queue that will place all submitted jobs on these nodes (without the need to specify ib=True):

set queue mpi resources_default.ib = True

But this doesn’t work. Instead, I’m getting
09/05/2021 18:18:47 L Insufficient amount of queue resource: ib (True != False) 09/05/2021 18:18:47 L Job will never run with the resources currently configured in the complex


Please unset this setting and try this
set queue mpi default_chunk.ib=True

1 Like

Great, it works! default_chunk is what I missed…

1 Like