Crash while openpbs deb install

It seems to be like openpbs was initially installed wrong, so I just decided to install OpenPBS all over, but this time using .deb files at instead of using ‘make install’ at github source file. It worked well for 3 deb files, client/debuginfo/devel. But when I try to install execution and server using dpkg, it returns

(Reading database … 222736 files and directories currently installed.)
Preparing to unpack openpbs-server_20.0.1-1_amd64.deb …
Unpacking openpbs-server (20.0.1-1) …
dpkg: error processing archive openpbs-server_20.0.1-1_amd64.deb (–install):
trying to overwrite ‘/etc/profile.d/pbs.csh’, which is also in package openpbs-client 20.0.1-1
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)

NOTE: /etc/pbs.conf and the PBS_HOME directory must be deleted manually

Processing triggers for libc-bin (2.31-0ubuntu9.2) …
Errors were encountered while processing:

I couldn’t use Ubuntu Software center because it keep give unmet dependency error. It seems like some file created while installing openpbs_client is clashing with openpbs_server installation. What should I do? I don’t think this program is built impossible to install both server and client

My suggestion…

Uninstall all PBS packages. Manually remove /etc/profile.d/pbs*

Only install one of server/execution/client packages. Server is a superset of execution and execution is a superset of client. The devel and debuginfo packages may optionally be installed.

It worked

But when I tried /etc/init.d/pbs start it returned

Starting PBS
PBS Home directory /var/spool/pbs needs updating.
Running /opt/pbs/libexec/pbs_habitat to update it.

/opt/pbs/libexec/pbs_habitat: 247: [[: not found
It appears that PostgreSQL has been upgraded independently of PBS.
The PBS database must be manually upgraded. Please refer to the
documentation/release notes for details.

What does it mean? Should I re-install postgresql package? I searched for documentation but there were no such related text

Is /bin/sh a symbolic link that points to something other than bash? The double brackets should not cause an error in the pbs_habitat shell script. If you want to undo all of your configuration and start from scratch…

  1. Stop PBS if it is running
  2. Remove or move /var/spool/pbs to another location if you want to retain it
  3. Restart PBS

That will cause pbs_habitat to rebuild /var/spool/pbs when PBS is restarted.

1 Like

It is solved! Now PBS starts normally.

However, When I try command qsub, It returns

Communication failure.
qsub: cannot connect to server songyi7 (errno=15031)

I’ve opened all necessary port, disabled firewall, changed pbs_iff and pbs_rcp to 4755, but it repeats. What can be other possibility?