Install openPBS 20.0.1 in Ubuntu 14.04

I’m finishing up a new cluster that is has Ubuntu 18.04 installed throughout the cluster’s servers. However, there are many users developing software that is based on Ubuntu 14.04 which they will be running PBS jobs from (they need to reference the development software in the jobs scripts).

I’ve updated expat, editline, cmake and python and referenced their installation locations with the appropriate ./configure options. I did also try to update libical but the build failed with some errors (libical doesn’t seem to be stopping openPBS from building). Right now I’m stuck for some reason with the newer version of python not being recognized.

I installed python 3.7 from deadsnakes repo which installed it to /usr/bin/python3.7. I referenced that with --with-python=/usr/bin/python3.7/ but the configure script stops with these last two lines.

checking whether /usr/bin/python3.7//bin/python3 version is >= 3.5… no
configure: error: Python interpreter is too old

I also tried --with-python=/usr/bin/ without luck. I could point the symlink /usr/bin/python3 to the python3.7 installation. But that would cause other python dependency errors.


To make some progress I went ahead and updated the symlink /usr/bin/python3 to point to the python 3.7 installation. That allows the openpbs configure script tp proceed beyond the python interpreter check.

Now it’s hung up on:

checking for editline… configure: error: editline headers not found.

This is after installing editline from source (and referencing the installation location with the configure option) and libedit-dev. I found this other old post where someone else ran into this problem. They seemed to solve it by installing libedit-dev which I already have installed.

I suspect there is some other dependency issue or maybe some shared library that isn’t recognized.

Any help is appreciated

Maybe You need to install python3-dev package?

Check dependency in this file:

python3-dev and python3.7-dev are both installed in /usr/bin/

I referenced python3.7 in the configure script with --with-python=/usr/bin/python3.7. The configure script returns:

checking whether /usr/bin/python3.7/bin/python3 version is >= 3.5… no
configure: error: Python interpreter is too old

I had similar problem. I have been installed python3.9 and had the same error. It disappeared when I removed python3.9 packages and installed python3 and python3-dev packages. Those packages installed me python3.6 and python3.6-devel :confused: . I use Centos, but maybe in Ubuntu is similar situation.