I’m finishing up a new cluster that is has Ubuntu 18.04 installed throughout the cluster’s servers. However, there are many users developing software that is based on Ubuntu 14.04 which they will be running PBS jobs from (they need to reference the development software in the jobs scripts).
I’ve updated expat, editline, cmake and python and referenced their installation locations with the appropriate ./configure options. I did also try to update libical but the build failed with some errors (libical doesn’t seem to be stopping openPBS from building). Right now I’m stuck for some reason with the newer version of python not being recognized.
I installed python 3.7 from deadsnakes repo which installed it to /usr/bin/python3.7. I referenced that with --with-python=/usr/bin/python3.7/ but the configure script stops with these last two lines.
checking whether /usr/bin/python3.7//bin/python3 version is >= 3.5… no
configure: error: Python interpreter is too old
I also tried --with-python=/usr/bin/ without luck. I could point the symlink /usr/bin/python3 to the python3.7 installation. But that would cause other python dependency errors.