Download broken, malware warning, no docs, no repo - is this really PRO?

Hi, I am digging into PBSPRO and my first impressions are very disappointing - this is what I found extremely not professional:

  • download link leads to a page without any relevant content
  • instead I get a warning about insecure content from my browser - malware on a website that provides software for clusters?
  • no documentation - wtf?
  • no repositories for debian / ubuntu Linux distributions?

You decided to use the word “professional” in your project - but what we see here is far away from any professionalism. Many very small unpaid open source projects do much better than this. It really looks like a satirical presentation of bad practices - “how not to call your project professional and present it on the internet”. Sorry, but somebody has to tell you.

What exactly is the problem? How can it be solved?

Here is a screenshot of the download area on the website:


Welcome to the community.

Re: Downloads – I double checked the download link ( and it resolves to a form for (optional) registration and that takes one to packages for downloads. I’m not sure why you are not seeing the downloads.

Re: HTTPS vs. HTTP – thanks for the reminder. I have a request into the site admin to add https for the site. As of today, it is still http only.

Re: Documentation – please check out the Contributor’s Portal (link is lower on that main webpage) – that area has a lot of useful information. (Typing “documentation” into the search box on the Contributor’s Portal brings you to a page of additional pointers too.)

Re: Additional Linux distributions – we are always looking for contributions from the community to expand the reach of PBS Pro. If you believe a Debian and/or Ubuntu package would be useful to the broader community, please consider submitting a contribution. (The contribution process is covered in the Contributor’s Portal.)

Thank you for your feedback.

1 Like


I faced the same issue : No download after registration.

Solved by deactivating my adblocker plugin.