Installation on Centos 8 Stream

Is anyone was installed properly Openpbs 20 on Centos8 Stream ???

$ cat /etc/centos-release
CentOS Linux release 8.4.2105
Not sure this info will help you as I have not used OpenPBS but PBSPro 20.1.2 does work. I used the rpms to install. I would expect that it should work fine.


Thanks for info. It’s seems to openpbs and pbs pro working on Centos 8 but not working on CentOS Stream release 8 :frowning:

Perhaps it would be more illuminating to post exactly what you’re doing and what the error is?

The simple answer to your question is: yes, people have compiled and used OpenPBS on CentOS8 stream, but I doubt that’s what you’re after.

It’s possible precompiled RPMs don’t work; that’s usually fixable too, but again: what is the problem?

Hi @alexis.cousein ,
The first problem was with installation openpbs via rpm packages. Problem with missing dependency Problem was described here:

I solved it compiling openpbs from sources.

Second, unresolved problem was with communication between server and nodes. It is described here:


I encounter several problems installing openpbs-20.0.1 on “CentOS Stream 8” with AMD architecture. Following the options for “CentOS-8” in the “INSTALL” instructions, my first problem begins at step 2 during the installation of the prerequisites “postgresql-*”. I am repeatedly warned about a non-existent user and group:

warning: user postgres does not exist - using root
warning: group postgres does not exist - using root

and later I am warned:

[/usr/lib/tmpfiles.d/postgresql.conf:1] Unknown user ‘postgres’.
warning: %transfiletriggerin(systemd-239-49.el8.x86_64) scriptlet failed, exit status 65

Error in scriptlet in rpm package postgresql-server
Verifying : postgresql-server-10.17-2.module_el8.5.0+865+7313c56 1/1 Installed products updated.


If I ignore these warnings, then the PBS services fail to start at Step 13. I could manually create a user “postgres” and provide a group, but that would be futile if something important is missing from “postgresql-server” or from “openpbs-20.0.1”. Do “postgresql-server” and “postgresql-contrib” need something extra?

Could someone please suggest how to improve the installation process on “CentOS Stream 8”?

My next installation problem seems similar. Later on, I receive warnings and errors because of the non-existence of a user “smmsp” in group “smmsp”. I guess that this user is part of “sendmail.” Shouldn’t these users be created automatically when they’re needed during the OpenPBS installation recipe? Does my operating system have some wrong settings that prevent scripted user creation?

I confirm that it is possible to install and run OpenPBS under CentOS-Stream-8, at least under some circumstances (AMD Threadripper). My particular installation problems are solved. Let me summarise, for the benefit of anyone who faces the same issues.

Installing the packages “postgresql” and “sendmail” (in steps 1 and 2 of official “INSTALL” instructions) should have created users “postgres” and “smmsp”, but failed to do so (on my system). It is sufficient to create these users manually, after the “yum” and “dnf” commands, but before compiling or executing the PBS post-install. For the sake of cleanliness, I delete any old versions of these users that might be left over from previous installation attempts.

sudo userdel -r postgres
sudo userdel -r smmsp
sudo rm -rf /home/postgres /home/smmsp

sudo dnf install postgresql-devel postgresql-contrib

sudo dnf install sendmail

sudo useradd -m postgres
sudo useradd -m smmsp

After fixing the critical error of missing users, the “postgresql” packages can be installed with just a few further warnings. I don’t know whether these warnings would occur generally or are specific to my machine and its type. The warnings were:

[/usr/lib/tmpfiles.d/pesign.conf:1] Line references path below legacy directory /var/run/, updating /var/run/pesign → /run/pesign; please update the tmpfiles.d/ drop-in file accordingly.
[/usr/lib/tmpfiles.d/postgresql.conf:1] Line references path below legacy directory /var/run/, updating /var/run/postgresql → /run/postgresql; please update the tmpfiles.d/ drop-in file accordingly.

I edited these two files to remove the offensive substring “/var”, from the first line of each.

sudo vi /usr/lib/tmpfiles.d/postgresql.conf
sudo vi /usr/lib/tmpfiles.d/pesign.conf

After performing these interventions, I now have OpenPBS 20.0.1 installed and running smoothly (CentOS-Stream-8; AMD Threadripper cpu).

I was running OpenPBS 20.0.1 on a “CentOS Stream 8” computer successfully for half a year, until a recent update of the operating system. Now I face multiple problems when I attempt to reinstall and start OpenPBS. The current system is “Linux 4.18.0-365.el8.x86_64” with “AMD threadripper pro 3995wx” architecture. The changes were great enough that my “Timeshift” application cannot revert to the previous system state. Postgresql version 12 is reinstalled and running OK.

Here, I would like to ask about the earliest problems that I encounter when reinstalling OpenPBS 20.0.1 from the source. I am following these official instructions:

Problem 1. At step 4 of the instructions, I run ./ and receive many errors like this:

test/tests/ while processing 'dist_ptl_testselftest_DATA'
automake: warning: wildcard $(srcdir: non-POSIX variable name
automake: (probably a GNU make extension)

I add one line to the end of


and replace every instance of




in the files test/tests/ and test/fw/ Are there any other Makefiles that need changing? This remedy was inspired by this link:

Problem 2. Running ./ again reveals a new type of error message. The last instance says:

src/tools/ warning: source file '$(top_srcdir)/src/lib/Libcmds/cmds_common.c' is in a subdirectory, src/tools/ but option 'subdir-objects' is disabled

I change one line in from

[*], m4_define([am_init_string], [-Wall foreign]))


[*], m4_define([am_init_string], [-Wall foreign subdir-objects]))

after taking inspiration from:

After these changes, doesn’t give me any further warnings or errors. These are my messages resulting from step 4 in the official instructions:

Generating configure script and Makefile templates.
libtoolize: putting auxiliary files in AC_CONFIG_AUX_DIR, 'buildutils'.
libtoolize: copying file 'buildutils/'
libtoolize: putting macros in AC_CONFIG_MACRO_DIRS, 'm4'.
libtoolize: copying file 'm4/libtool.m4'
libtoolize: copying file 'm4/ltoptions.m4'
libtoolize: copying file 'm4/ltsugar.m4'
libtoolize: copying file 'm4/ltversion.m4'
libtoolize: copying file 'm4/lt~obsolete.m4' installing 'buildutils/compile' installing 'buildutils/missing'
src/cmds/ installing 'buildutils/depcomp'

I suffer other problems later on, when I try to start the compiled pbs service. For now, I would appreciate advice or confirmation that my changes to help are correct, necessary, and sufficient. Please check the “sanity” of my tinkering. Is there a simple reason why behaved so badly on a straightforward CentOS machine? Is there a more elegant remedy possible?